Back to overview
Downtime
[EU Data Center] Incident with Website
Nov 06 at 07:36am CET
Affected services
Website
Resolved
Nov 06 at 07:48am CET
Our planned maintenance is complete, and services are now up and running smoothly. Thank you for your patience and support!
Affected services
Website
Updated
Nov 06 at 07:41am CET
Only our EU data center is undergoing planned maintenance. Our US data center is fully operational, and services are running smoothly.
Affected services
Website
Created
Nov 06 at 07:36am CET
We’re taking a quick break for planned maintenance. We'll be back up and running in about 20 minutes.
Affected services
Website