Back to overview
Downtime
[US Data Center] Incident with Website
Nov 12 at 08:18am CET
Affected services
Website
Resolved
Nov 12 at 08:39am CET
Our planned maintenance is complete, and services are now up and running smoothly. Thank you for your patience and support!
Affected services
Website
Created
Nov 12 at 08:18am CET
We're temporarily offline for scheduled maintenance at our US data center and expect to be back online in approximately 20 minutes. Our EU data center is unaffected and remains fully operational.
Affected services
Website